Downloading Your
Financial Statements
to Excel

Downloading Data from CU*BASE to
PC

INTRODUCTION

How can I get my favorite financial statement from CU*BASE into my Excel
worksheet? How can I get this data in a way that I makes it easy to perform
calculations and format the results for to make prettier presentations?

Independent PCs, LANs and WANSs are a critical part of the online CU*BASE
environment. More and more, day-to-day credit union activities require that
one of your most important assets—data—be available for analysis and
manipulation on a platform other than CU*BASE.

To that end, we are pleased to provide ability to download your financial
statements from within CU*BASE directly to Excel. This option makes
translating data from CU*BASE to and Excel simple to do, giving you results
that you can immediately use to perform calculations and to format using
today’s most popular PC applications.
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CREATING THE FILE FROM WITHIN
CU*BASE

PREPARING THE FILE

In this step you begin in CU*BASE to select the financial statement report
that you would like to download into Excel as well as print out a printed

copy. Begin in Print CU Financials on the General Ledger (MNGELE) menu
and select your report and your parameters.

1. From this screen select Export to file & print report.

Session 0 CUFBASE GOLD Edition - FINANCIAL STATEMENT REPORT B o ]
File Edit Tools Help

FINANCIAL STATEMENT REPORT

Corp ID 1 ABC TESTING CREDIT UNION

Report # 2 INCOME STATEMENT - TRIAL BALANCE
Report Options Response

e 10 .Iob queue
Summarize locations Copies m

Single location # Opt fonal Printer
Print zero balances

Print G/L account #

[] Print accounting format
Printiview options

‘é-'Exporl to file & print reportf () view on CRT (7)Report only

Report comment

Run/Next Report

Branch Selection

New Report

2. Name your exported results.

Session 0 CU*BASE GOLD Edition - EXPORT WINDOW
File name |

Export immediately File will be stored in your credit union's QUERYxx library (where xx is your 2-character CUID).

The next step is to take the database file created in CU*BASE Report
Builder, and transfer it to a file stored on your PC.
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DOWNLOADING THE FILE TO THE PC

1. Once you select to download the file, the following screen will appear.

CEoX

ata Transfer From AS/400

File View Help

A M
AS/400
Syztem name:
File: name:
PC

File: parne:

Output device:

|WESCPROD.CUBASE ORG ~|

QUERTH/TESTDATAR Browse. ..
Data Options. .. ¥

|File ~|  Detals..
|c:'\cubasedownIoads'\testdataE Browse...
Format Optioneg...

| Transfer data from A5./400 |

2. Complete all of the following fields (none are case-sensitive):

Field Descriptions

DO NOT use the
Browse or Data
Options
buttons—they
can cause a
significant delay
in processing
your transfer!

Field Name Description
iSeries These settings refer to where the data is coming from.
System name This designates the iSeries system from which the files will

be downloaded. For online credit unions, this will read
WESCPROD.CUBASE.ORG and should not be changed.

File name Enter your credit union’s Query library name, a forward
slash, then the name of the database file to be downloaded,
as in the following sample:

QUERYxx/FILENAME

(For the xx, fill in your credit union’s two-character credit

union ID)

PC These settings refer to where the data is going.

Output device This setting controls the format in which the data will be
downloaded. Click [¥] and choose File.

File name Enter the path (the storage location, both drive and folder)

and file name where the downloaded file should be stored on
your PC. Use backslashes between the folder name and the
file name, as in the follow sample:

C:\CUBASEDOWNLOADS\FILENAME

HINT: Locating downloaded files and keeping your
computer storage clean will be much easier if you
designate a special folder on your PC to receive all
downloaded files, such as c:\cubase, c:\downloads,
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Field Name Description

or something similar.

3. From the File menu, choose Properties.

4. Be sure that the option, Convert CCSID 65535 is selected, and then
click OK.

Properties @

Conversions | Library List | Display | Connection | Startup ‘

General options

[+ Convert CCSID 65535 €— This option must be
selected in order for the

3 file to be in the correct

[ format for use on the PC.

ASCIl Text options If the data looks garbled

[ Preserve t=bs when you try to open the
file on your PC, this is

Excelfile options usually the culprit!

[ ConvertExcel date and time cells to IBM i date or fime

Allow numeric data in character columns to be converted to
character data

0K | Cancel ‘ Apply | Help |

S. To begin the transfer process, click the Transfer data from AS/400
button. A series of messages will appear to report on the progress of the
transfer.

If you experience problems downloading, it may be because
you have not been authorized to receive downloads from
the CU*BASE iSeries. Downloading files from the CU*BASE
iSeries requires special security authorization by a
CU*BASE representative. If you or a member of your staff
needs to be able to download files, please contact a Client
Service Representative to set up the proper permissions.
Authorization by your credit union’s designated Security
Officer is required to grant these permissions and confirm
this clearance on a monthly basis.

6. When the transfer is complete, the following message will appear: Click
OK and the Data Transfer dialog box will reappear. Click Close [X] to
return to the CU*BASE menu. (See below for details on saving the
transfer request.)

Transfer to File Complete E|
Notice the number shown under “Rows

2y transferred.” This indicates the total
Transfer statistics: number of records that were
) 0 / downloaded, and should match the
number of records found when running
Rows transferned: 97 the original report.

‘ Also make sure that your spreadsheet
or other PC application can handle that

many rows of datal
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The text file is now saved in the designated folder, and can be opened in any
spreadsheet or other PC application.
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OPENING A DOWNLOADED FILE USING

MICROSOFT EXCEL

NOTE: The following is shown as an example only. For complete
information on using Microsoft Excel or any of the many popular PC
spreadsheet applications, refer to your software reference manual.

1. In Excel, from the File menu, choose Open.

2)X)

Open
Look in: [ #5400 Downloads v | @ ®] | Q )( [ _='| * Tools »
A Mame Dake Modified Siz
L‘aﬁ B Headings For MBRLIST, xls 7/7}2003 2:18 PM 14K
My Recent || MHhpeadings, s 12§17/1999 9:42 AM 16K
Documents
1 abels b L1ST.doc 2}18/2004 1:32 PM 46 K
- Btk s 5/11/2006 3:03 PM 14K
_,.J EMBRLIST s 3 15/2006 3:20 FM 14K
Favorites TESTDATA 713/2006 4147 PM 16K
TESTDATA.FOF 7i3/2006 4:47 PM 1K
—
Desktop
My Documents
< >
-
gl | Flename: v

2. In the Files of Type list, choose All Files (*.*). Use the Look in list to
open the folder where the file was downloaded.

3. Select the file name to be opened, choosing the file without the *.FDF
extension, then click Open. A series of windows will appear to help you
separate the text in the file into separate columns.

4. Select Delimited and click Next to proceed.
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Select Delimited
on this screen.

On this screen,
check the Comma
checkbox.

Text Import Wizard - Step 1 of 3

The Text Wizard has determined that your data is Fixed Width,

If this is correct, choose Mext, or choose the data bype that best describes vour data,
Criginal data type

Choose the file type that best describes your data:

- Chatacters such as commas or tabs separate each field.

() Fixed width - Fields are aligned in columns with spaces between sach field,
Start import at row: 1 E File: origin: 437 : OEM United States w
Preview of File HVWCUBASEVAKMDOWN,
. CURRENT, CURRENT, LAST YEAR, LAST YERR,,,,,|™
PERIOL, T-T-D, PERIOD, T-T-D

)

, INCOME,, .00, .00,.00,.00,.00,.00,. 00,.00,
, INCOME FROM LOANS,,.00,.00,.00,.00,.00,.00,.00,.00,
1, INT INCOME - SHARE PLEDGE LOANS,, 103 76-,11388. 30-, 1369 4

FN |o—| |4h |co |N |»—-

bs

Cancel

[ mext> ][ Ensh |

5. On the next screen, check the Comma checkbox, and select Next.

Text Import Wizard - Step 2 of 3

This screen lets wou set the delimiters vour data contains, You can see
hiowe your text is affected in the preview below,

Delimiters ) -
[] Treat consecutive delimiters as one
[J1ab [ semicalon
[dapace [ Text qualifisr: | b
Daka preview
CURRENT 5
PERIOD
INCOME .00 muls}
INCOME FROM LOANS . on . oa
1 INT INCOME - SHARE PLEDGE LOANS Loz 7e- L1388 {0
< >

[ Cancel ” < Back ” Mext = H Finish

6. Click Finish on the next screen.

Text Import Wizard - Step 3 of 3

This screen lets vou seleck each column and set

Colurin data Format
the Data Format,

(%) General

‘General' converts numeric values bo numbers, date () Text
walues to dates, and all remaining walues to text, O pate: MDY .

() Do nct import calumn (skip)

Daka preview

Shel2 annval Cepereneral Cohels
CURRENT e
PERIOD
INCOME oo . oo
INCOME FROM LOANS ao Rula]
INT INCOME - SHARE PLEDGE LOANE Loz, 7e- L1222,
>

Cancel ][ < Back
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Once the data has been pulled into the spreadsheet, you may format it, add
headings, set up calculations, and perform any other spreadsheet function
you wish. Negative numbers arrive ready for calculations with a negative
symbol appearing with the number. Be sure to save the file as an Excel
document.

B3 Microsoft Excel - AKMDOWN

@_1 File Edit ‘iew Insert Format Tools Data  Window Help  PDF Create!  Adobe PDF -8 X
= L -0 - B I U|EE=|8$ %][E “
i bnl B T
0~ BT ! s !
A1 - &
A B | C | D | E | F | Gm

1 CURRENT CLURRENT LAST ¥l LAST

2 PERIOD Y-T-D PERIO W-T-[

3 INCOME 0 I} 0

4 INCOME FROM LOANS ] 0 0

5 [ 1 INTINCOME - SHARE PLEDGE LOAMNS -103.76 -11388.3 -1369.4 -3

B |2 IMTINCOME - SHARE PLEDGE LOAMNS -1.4 -62.55 -84.02

7|3 IMT INCOME - SHARE PLEDGE LOAMS -13.62 -857.09 -03 -

S |4 IMTINCOME - SHARE PLEDGE LOAMNS -11.64 171427 -284.7 -1

9 |5 IMTINCOME - SHARE PLEDGE LOAMNS 213 -295.79 0

10 1) INT INCOME - SIGNATURE LOAMNS -3166.19 -4BE97E5.09 9124653 -523
11 2 INT INCOME - SIGNATURE LOAMNS =229 23 -30931.69) -3484 49 -19
12 [ 3 INT INCOME - SIGNATURE LOAMNS -2837a8 415193 -6182.45 =32
13| 4 INT INCOME - SIGHNATURE LOAMNS -4585.93 Sf3F7A.58 1318827 -7
141 & IMT INCORE - SUERATLIRE | OUARKS a5 71 REFreEtl n v
M4 b M AKMDOWN / |2 3
Ready I

MISCELLANEOUS HINTS AND TIPS

Although downloaded data can be opened using a word processing
application, such as Microsoft Word, it is generally not recommended.
Remember that the file is a simple text file, with spaces to separate the
fields and no formatting. Choosing a proportionally spaced font, for
example, may make the data difficult to read.

If you wish to use the data as part of a mail merge (for personalized form
letters or mailing labels), open the data in a spreadsheet program and
add one row at the top for the field labels. Then use your word
processing program to create the form letter, using the spreadsheet as
the database from which the variable information will be pulled.

Data such as amounts, dates, ZIP codes, etc., can be formatted either
when the custom report is created, or after the data has been pulled into
your spreadsheet program, according to your preference.

If upon opening the file you see a series of numbers and letters that
appear to be “garbage,” it is usually because the “Convert CCSID 65535”
flag was not checked when the download transfer was performed. Repeat
the download procedure, using File, Properties to select the conversion
option.

SAVING TRANSFER SETTINGS

If you perform file transfers often, one way to speed things up and make sure
that all settings are set correctly (especially the conversion format you
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selected using the File, Properties command), the transfer request can be
saved. This feature simply stores all of the file names and other settings
from the Data Transfer window so that they can be quickly filled in for you
the next time a transfer is performed.

1. When closing the Data Transfer window after a transfer has been set up
or performed, the following message may appear:

iSeries Data Transfer

:‘Z)‘ Do you want to save this transfer request?
-

es Mo | Cancel |

If this is a transfer you perform often, click Yes.
OR

1. At any time in the Data Transfer window, choose the File menu, then
choose Save. If the transfer has not been saved before, the following
dialog box will appear:

HINT: If you have already saved the transfer once but wish
to use a different name this time, use File, Save As

instead.
Save As E|E |
Savein | ) cubasedownloads j & rj( ,

File name: |testingtlansfertosave
Save as lype: |Data Transfer From AS /400 files [* dif) ﬂ Cancel

2. Enter a name for the transfer request, then click Save. The request will
be saved and the CU*BASE menu will reappear.

USING A SAVED TRANSFER REQUEST

1. After creating the database file as usual, display the Data Transfer
window. (This is accessed via Print CU Financials on the General
Ledger (MNGELE) menu.

2. From the File menu, choose Open, select the desired transfer request
from the list and click Open.

3. Make changes to the request specifics as needed (such as the PC file
name, etc.), then click Transfer data from AS/400 to begin the transfer
as usual.
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